MacDive
The digital dive log for macOS and iOS


FAQiOSMac

Frequently Asked Questions


OS Compatibility

What do I need to run MacDive?

MacDive is compatible with the following:

iPhone iOS 9 or later
macOS 10.10 (Yosemite) or later

iCloud

Syncing via iCloud on macOS requires Mac OS X 10.11 or later. Dropbox is available for 10.10+.

Support for older versions of macOS

If you're running an older operating system on your Mac, we do have older builds available. They no longer receive bug fixes or device updates, however we can provide them if necessary. Please drop us an email on support@mac-dive.com and we'd be happy to send one over.

Note that older versions will not necessarily support all of the devices or features listed on the website. Please check with us and we can let you know.

OS X Lion / Mountain Lion / Mavericks

MacDive has recently dropped support for OS X 10.7 and 10.8. A very small number of MacDive users still have these versions of OS X. Third party frameworks that we use are also phasing them out, and there are new features in more recent versions that benefit a much larger number of users. Apologies for any inconvenience. Please contact support if you are still using these operating systems as we do have a modified version of MacDive 2.6.0 available, with some minor caveats.

We have also recently dropped support for OS X 10.9, Mavericks. Dropbox requires 10.10+, so we are unable to provide syncing for previous versions. As this is a huge part of MacDive, we felt it best to set the baseline to 10.10. We apologise for any inconvenience - however based on stats, a very small portion of people are still on 10.9. We can provide you a version of MacDive that has no support for syncing if necessary for 10.9.


Follow @MacDiveApp